import Foundation
let pattern = #"€\D*(\d+)[^<]*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<span class="price" id="old-price-3">€ 200,00 </span>
<span class="price" id="product-price-3">€ 80,00</span>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)