using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"€\D*(\d+)[^<]*";
string substitution = @"$1";
string input = @"<span class=""price"" id=""old-price-3"">€ 200,00 </span>
<span class=""price"" id=""product-price-3"">€ 80,00</span>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}