const regex = /€\D*(\d+)[^<]*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('€\\D*(\\d+)[^<]*', 'g')
const str = `<span class="price" id="old-price-3">€ 200,00 </span>
<span class="price" id="product-price-3">€ 80,00</span>`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);