package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`€\D*(\d+)[^<]*`)
var str = `<span class="price" id="old-price-3">€ 200,00 </span>
<span class="price" id="product-price-3">€ 80,00</span>`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}