re = /€\D*(\d+)[^<]*/
str = '<span class="price" id="old-price-3">€ 200,00 </span>
<span class="price" id="product-price-3">€ 80,00</span>'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result