import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+)\\(([^()]+)\\)";
final String string = "sin(10+sin(sin(90+sin(sin(sin(10))))))+cos(10)+tan(100.00)\n"
+ "sin(10+sin(sin(90+sin(sin(-0.5440211108893698)))))+-0.8390715290764524+-0.5872139151569291";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}