re = /(\w+)\(([^()]+)\)/m
str = 'sin(10+sin(sin(90+sin(sin(sin(10))))))+cos(10)+tan(100.00)
sin(10+sin(sin(90+sin(sin(-0.5440211108893698)))))+-0.8390715290764524+-0.5872139151569291'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end