const regex = new RegExp('(\\w+)\\(([^()]+)\\)', 'gm')
const str = `sin(10+sin(sin(90+sin(sin(sin(10))))))+cos(10)+tan(100.00)
sin(10+sin(sin(90+sin(sin(-0.5440211108893698)))))+-0.8390715290764524+-0.5872139151569291`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}