use strict;
my $str = 'sin(10+sin(sin(90+sin(sin(sin(10))))))+cos(10)+tan(100.00)
sin(10+sin(sin(90+sin(sin(-0.5440211108893698)))))+-0.8390715290764524+-0.5872139151569291';
my $regex = qr/(\w+)\(([^()]+)\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}