import re
regex = re.compile(r"(\w+)\(([^()]+)\)", flags=re.MULTILINE)
test_str = ("sin(10+sin(sin(90+sin(sin(sin(10))))))+cos(10)+tan(100.00)\n"
"sin(10+sin(sin(90+sin(sin(-0.5440211108893698)))))+-0.8390715290764524+-0.5872139151569291")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")