#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[\da-z]+|[\dA-Z]+)$"
Local $sString = "TY5TF45TF463CHB7437R" & @CRLF & _
"ecrx3yt4cx345748bnc7547" & @CRLF & _
"745367456475647378563745" & @CRLF & _
"hdgfsdgfsdjfgshdgshdgf" & @CRLF & _
"DHFGSDHGFSHDGFHSGFHSDFH" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"sshd434gfhdghHSDGFH324234SDFHSG" & @CRLF & _
"SDASGDASDhghgshdfsh" & @CRLF & _
"dhf hsh-d-f-837_483@^%f#@^#2482" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")