re = /^(?:[\da-z]+|[\dA-Z]+)$/m
str = 'TY5TF45TF463CHB7437R
ecrx3yt4cx345748bnc7547
745367456475647378563745
hdgfsdgfsdjfgshdgshdgf
DHFGSDHGFSHDGFHSGFHSDFH
sshd434gfhdghHSDGFH324234SDFHSG
SDASGDASDhghgshdfsh
dhf hsh-d-f-837_483@^%f#@^#2482
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end