using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[\da-z]+|[\dA-Z]+)$";
string input = @"TY5TF45TF463CHB7437R
ecrx3yt4cx345748bnc7547
745367456475647378563745
hdgfsdgfsdjfgshdgshdgf
DHFGSDHGFSHDGFHSGFHSDFH
sshd434gfhdghHSDGFH324234SDFHSG
SDASGDASDhghgshdfsh
dhf hsh-d-f-837_483@^%f#@^#2482
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}