import Foundation
let pattern = #"^(?:[\da-z]+|[\dA-Z]+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
TY5TF45TF463CHB7437R
ecrx3yt4cx345748bnc7547
745367456475647378563745
hdgfsdgfsdjfgshdgshdgf
DHFGSDHGFSHDGFHSGFHSDFH
sshd434gfhdghHSDGFH324234SDFHSG
SDASGDASDhghgshdfsh
dhf hsh-d-f-837_483@^%f#@^#2482
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)