package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[\da-z]+|[\dA-Z]+)$`)
var str = `TY5TF45TF463CHB7437R
ecrx3yt4cx345748bnc7547
745367456475647378563745
hdgfsdgfsdjfgshdgshdgf
DHFGSDHGFSHDGFHSGFHSDFH
sshd434gfhdghHSDGFH324234SDFHSG
SDASGDASDhghgshdfsh
dhf hsh-d-f-837_483@^%f#@^#2482
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}