// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[\da-z]+|[\dA-Z]+)$").unwrap();
let string = "TY5TF45TF463CHB7437R
ecrx3yt4cx345748bnc7547
745367456475647378563745
hdgfsdgfsdjfgshdgshdgf
DHFGSDHGFSHDGFHSGFHSDFH
sshd434gfhdghHSDGFH324234SDFHSG
SDASGDASDhghgshdfsh
dhf hsh-d-f-837_483@^%f#@^#2482
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}