# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:[\da-z]+|[\dA-Z]+)$"
test_str = ("TY5TF45TF463CHB7437R\n"
"ecrx3yt4cx345748bnc7547\n"
"745367456475647378563745\n"
"hdgfsdgfsdjfgshdgshdgf\n"
"DHFGSDHGFSHDGFHSGFHSDFH\n\n\n\n\n"
"sshd434gfhdghHSDGFH324234SDFHSG\n"
"SDASGDASDhghgshdfsh\n"
"dhf hsh-d-f-837_483@^%f#@^#2482\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.