# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.{1,3}(*SKIP)(*F)|./_/gm;t' <<< "h
he
hel
hello there
"