// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.{1,3}(*SKIP)(*F)|.").unwrap();
let string = "h
he
hel
hello there
";
let substitution = "_";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}