$re = '/^.{1,3}(*SKIP)(*F)|./m';
$str = 'h
he
hel
hello there
';
$subst = "_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;