use strict;
my $str = 'h
he
hel
hello there
';
my $regex = qr/^.{1,3}(*SKIP)(*F)|./mp;
my $subst = '_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";