re = /^.{1,3}(*SKIP)(*F)|./m
str = 'h
he
hel
hello there
'
subst = '_'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result