package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.{1,3}(*SKIP)(*F)|.`)
var str = `h
he
hel
hello there
`
var substitution = "_"
fmt.Println(re.ReplaceAllString(str, substitution))
}