using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[^:\n]+:).*(\n\1.*)*";
string input = @"Subject: this is text not to be matched
Subject2: this is text to be recognized.
Subject2: This text can be different.
Subject2: ..and this text will be also matched in the first match.
Subject3: This text alone.
this text will not be matched
Subject2: New start of a new match.
Subject2: continuation of the above line";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}