import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^[^:\\n]+:).*(\\n\\1.*)*";
final String string = "Subject: this is text not to be matched\n"
+ "Subject2: this is text to be recognized.\n"
+ "Subject2: This text can be different.\n"
+ "Subject2: ..and this text will be also matched in the first match.\n"
+ "Subject3: This text alone.\n"
+ "this text will not be matched\n"
+ "Subject2: New start of a new match.\n"
+ "Subject2: continuation of the above line";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}