const regex = /(^[^:\n]+:).*(\n\1.*)*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^[^:\\n]+:).*(\\n\\1.*)*', 'gm')
const str = `Subject: this is text not to be matched
Subject2: this is text to be recognized.
Subject2: This text can be different.
Subject2: ..and this text will be also matched in the first match.
Subject3: This text alone.
this text will not be matched
Subject2: New start of a new match.
Subject2: continuation of the above line`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}