use strict;
my $str = 'Subject: this is text not to be matched
Subject2: this is text to be recognized.
Subject2: This text can be different.
Subject2: ..and this text will be also matched in the first match.
Subject3: This text alone.
this text will not be matched
Subject2: New start of a new match.
Subject2: continuation of the above line';
my $regex = qr/(^[^:\n]+:).*(\n\1.*)*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}