import Foundation
let pattern = #"(^[^:\n]+:).*(\n\1.*)*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Subject: this is text not to be matched
Subject2: this is text to be recognized.
Subject2: This text can be different.
Subject2: ..and this text will be also matched in the first match.
Subject3: This text alone.
this text will not be matched
Subject2: New start of a new match.
Subject2: continuation of the above line
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)