# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\$([0-9\.\,]+).+$/$1/gm;t' <<< "$12.69/CS
$10000.69/CS
$10,000/CLAJ
$10,000.99/CA
$10,000,000,000,000.00/Cadflaj"