import re
regex = re.compile(r"^\$([0-9\.\,]+).+$", flags=re.MULTILINE)
test_str = ("$12.69/CS\n"
"$10000.69/CS\n"
"$10,000/CLAJ\n"
"$10,000.99/CA\n"
"$10,000,000,000,000.00/Cadflaj")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)