const regex = /^\$([0-9\.\,]+).+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\$([0-9\\.\\,]+).+$', 'gm')
const str = `\$12.69/CS
\$10000.69/CS
\$10,000/CLAJ
\$10,000.99/CA
\$10,000,000,000,000.00/Cadflaj`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);