// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\$([0-9\.\,]+).+$").unwrap();
let string = "$12.69/CS
$10000.69/CS
$10,000/CLAJ
$10,000.99/CA
$10,000,000,000,000.00/Cadflaj";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}