$re = '/^\$([0-9\.\,]+).+$/m';
$str = '$12.69/CS
$10000.69/CS
$10,000/CLAJ
$10,000.99/CA
$10,000,000,000,000.00/Cadflaj';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;