use strict;
my $str = '$12.69/CS
$10000.69/CS
$10,000/CLAJ
$10,000.99/CA
$10,000,000,000,000.00/Cadflaj';
my $regex = qr/^\$([0-9\.\,]+).+$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";