#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[+\-]?(\d+\.\d*|\d*\.\d+|\d+)([eE][+\-]?\d+)?"
Local $sString = "2" & @CRLF & _
"0089" & @CRLF & _
"-0.1" & @CRLF & _
"+3.14" & @CRLF & _
"4." & @CRLF & _
"-.9" & @CRLF & _
"2e10" & @CRLF & _
"-90E3" & @CRLF & _
"3e+7" & @CRLF & _
"+6e-1" & @CRLF & _
"53.5e93" & @CRLF & _
"-123.456e789" & @CRLF & _
"" & @CRLF & _
"abc" & @CRLF & _
"1a" & @CRLF & _
"1e" & @CRLF & _
"e3" & @CRLF & _
"99e2.5" & @CRLF & _
"--6" & @CRLF & _
"-+3" & @CRLF & _
"95a54e53"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")