import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[+\\-]?(\\d+\\.\\d*|\\d*\\.\\d+|\\d+)([eE][+\\-]?\\d+)?";
final String string = "2\n"
+ "0089\n"
+ "-0.1\n"
+ "+3.14\n"
+ "4.\n"
+ "-.9\n"
+ "2e10\n"
+ "-90E3\n"
+ "3e+7\n"
+ "+6e-1\n"
+ "53.5e93\n"
+ "-123.456e789\n\n"
+ "abc\n"
+ "1a\n"
+ "1e\n"
+ "e3\n"
+ "99e2.5\n"
+ "--6\n"
+ "-+3\n"
+ "95a54e53";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}