# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[+\-]?(\d+\.\d*|\d*\.\d+|\d+)([eE][+\-]?\d+)?"
test_str = ("2\n"
"0089\n"
"-0.1\n"
"+3.14\n"
"4.\n"
"-.9\n"
"2e10\n"
"-90E3\n"
"3e+7\n"
"+6e-1\n"
"53.5e93\n"
"-123.456e789\n\n"
"abc\n"
"1a\n"
"1e\n"
"e3\n"
"99e2.5\n"
"--6\n"
"-+3\n"
"95a54e53")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.