// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[+\-]?(\d+\.\d*|\d*\.\d+|\d+)([eE][+\-]?\d+)?").unwrap();
let string = "2
0089
-0.1
+3.14
4.
-.9
2e10
-90E3
3e+7
+6e-1
53.5e93
-123.456e789
abc
1a
1e
e3
99e2.5
--6
-+3
95a54e53";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}