using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[+\-]?(\d+\.\d*|\d*\.\d+|\d+)([eE][+\-]?\d+)?";
string input = @"2
0089
-0.1
+3.14
4.
-.9
2e10
-90E3
3e+7
+6e-1
53.5e93
-123.456e789
abc
1a
1e
e3
99e2.5
--6
-+3
95a54e53";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}