use strict;
my $str = '2
0089
-0.1
+3.14
4.
-.9
2e10
-90E3
3e+7
+6e-1
53.5e93
-123.456e789
abc
1a
1e
e3
99e2.5
--6
-+3
95a54e53';
my $regex = qr/[+\-]?(\d+\.\d*|\d*\.\d+|\d+)([eE][+\-]?\d+)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}