#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)<body.*?>(.*?)<\/body>"
Local $sString = "7687687toyi7fy" & @CRLF & _
"<body style="box-sizing: border-box; height: inherit; width: inherit; " & @CRLF & _
"margin: 0px; overflow: hidden">" & @CRLF & _
"lkjlknkjyyugtfiytfif" & @CRLF & _
"</body>" & @CRLF & _
"</html>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")