const regex = /<body.*?>(.*?)<\/body>/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<body.*?>(.*?)<\\\/body>', 'gms')
const str = `7687687toyi7fy
<body style="box-sizing: border-box; height: inherit; width: inherit;
margin: 0px; overflow: hidden">
lkjlknkjyyugtfiytfif
</body>
</html>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}