re = /<body.*?>(.*?)<\/body>/m
str = '7687687toyi7fy
<body style="box-sizing: border-box; height: inherit; width: inherit;
margin: 0px; overflow: hidden">
lkjlknkjyyugtfiytfif
</body>
</html>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end