$re = '/<body.*?>(.*?)<\/body>/ms';
$str = '7687687toyi7fy
<body style="box-sizing: border-box; height: inherit; width: inherit;
margin: 0px; overflow: hidden">
lkjlknkjyyugtfiytfif
</body>
</html>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);