package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)<body.*?>(.*?)<\/body>`)
var str = `7687687toyi7fy
<body style="box-sizing: border-box; height: inherit; width: inherit;
margin: 0px; overflow: hidden">
lkjlknkjyyugtfiytfif
</body>
</html>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}