#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?<=Cartoon Car \()[a-z]+(?: +[a-z]*);[^;]+(?=.*;)"
Local $sString = "Focal Point (BUGS BUNNY; bugs.bunny@looonytune.car; 888-555-1111)\nCartoon Car (DAFFY DUCK; daffyduck@disney.com; 888-555-1112)\nCartoon Car (243; daffyduck@disney.com; 888-555-1113)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")