import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Cartoon Car \\()[a-z]+(?: +[a-z]*);[^;]+(?=.*;)";
final String string = "Focal Point (BUGS BUNNY; bugs.bunny@looonytune.car; 888-555-1111)\\nCartoon Car (DAFFY DUCK; daffyduck@disney.com; 888-555-1112)\\nCartoon Car (243; daffyduck@disney.com; 888-555-1113)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}