using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=Cartoon Car \()[a-z]+(?: +[a-z]*);[^;]+(?=.*;)";
string input = @"Focal Point (BUGS BUNNY; bugs.bunny@looonytune.car; 888-555-1111)\nCartoon Car (DAFFY DUCK; daffyduck@disney.com; 888-555-1112)\nCartoon Car (243; daffyduck@disney.com; 888-555-1113)";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}