import re
regex = re.compile(r"(?<=Cartoon Car \()[a-z]+(?: +[a-z]*);[^;]+(?=.*;)", flags=re.MULTILINE | re.IGNORECASE)
test_str = "Focal Point (BUGS BUNNY; bugs.bunny@looonytune.car; 888-555-1111)\\nCartoon Car (DAFFY DUCK; daffyduck@disney.com; 888-555-1112)\\nCartoon Car (243; daffyduck@disney.com; 888-555-1113)"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")