import Foundation
let pattern = #"(?<=Cartoon Car \()[a-z]+(?: +[a-z]*);[^;]+(?=.*;)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"Focal Point (BUGS BUNNY; bugs.bunny@looonytune.car; 888-555-1111)\nCartoon Car (DAFFY DUCK; daffyduck@disney.com; 888-555-1112)\nCartoon Car (243; daffyduck@disney.com; 888-555-1113)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)